V0.8.0 does not show cleaner for installed Firefox on Win7 Starter 32bit

Forum tags: 


I just downloaded and tested Bleachbit V0.8.0 on a Windows 7 Starter 32bit. It seems to be exactly what I was searching for, thanks for that! One drawback, though: The Firefox, which I am using right now to write this message, is not shown as a cleaning option. Could this be due to some configuration I made? The documentation says, not the application will be detected but its cache. Maybe there is none? But that seems unlikely. How could I check what is going on? It's V3.6.8 of Firefox. And it is a German system. Maybe it is a localization issue.

Please tell me anything to check and I will do so.

Best regards,

Do you have a file called $USERPROFILE\Application Data\Mozilla\Firefox\Profiles\cookies.sqlite? The $USERPROFILE is something like c:\users\klaus\ . You may have to tell Windows to show hidden files and folders, so you can see this path.

Andrew, lead developer


thanks for the fast response! I searched the whole disk for the file (after enabling display of hidden files) and the only hit is directly in the folder of my profile:


So it seems the path to the cookie file cannot be hard-coded :-/

And while searching I ran into this file:


A directory called OfflineCache might be worth a look when it comes to erasing traces.

I mentioned the pattern slightly wrong: In the profiles directory, BleachBit checks each profile. In other words, your path looks OK.

On my Windows 7, BleachBit finds it as

C:\Users\z\Application Data\Mozilla\Firefox\Profiles\ukt30xe0.default\cookies.sqlite

Do you have the folder C:\Users\Username\Application Data ? You should. It is a compatibility shortcut that points to C:\Users\Username\AppData\Roaming.

Also, Username is your login username, and that you are running BleachBit as the same user account?

Andrew, lead developer

No, this folder is not present.
Yes, I run Bleachbit from the account where I do all these checks. It is the only account on this machine (at least the only one a user can use to log in).

There is an Application Data folder in C:\Users\Default, but not under my user name. Strange. It is a Netbook which came with lots of bloatware. Maybe the manufacturer messed with the default profile or the way how new user accounts are created.

And just to mention how I checked whether the folder is present or not:
- enabled display of system files in folder options
- enabled display of hidden file in folder options
- looked in the explorer window if the folder ist there -> not
- typed the location into the address bar -> no success
- tried cmd.exe and cd -> folder not found

I cannot remember that this folder should be more hidden than that. I have another Win 7 machine where I am sure that the folder exists. Some time ago I had to port a program from XP to Win7 and went spelunking into these folders. But maybe I missed something here on my machine. If not then it seems to be one possible setting.

You are apparently missing what is called a directory junction point as described here


It needs to be created with the mklink command. Do you need more specifics?

Andrew, lead developer

Hm I can create the junction point, as a workaround this would do it. I know how, thanks.

In the long run it would be good if BleachBit used the respective Windows APIs like SHGetKnownFolderPath to detect the location of special folders like Application Data. But I don't know how you develop and how you create the builds for different platforms so this might not be possible. But it would solve the problem :)

I committed a change for the next release which may help. Please watch for the beta (no date at this time): to be notified, subscribe to the news feed by using the orange icon on the right. The next release will use the environment variable %localappdata% instead of %userprofile% for some paths, so it won't rely on redirection as much. (A special trick was required to make this work on Windows XP, which doesn't define %localappdata%.)

Andrew, lead developer

Cool, thanks! I will test it as soon as it's out.