BleachBit 1.9.2 doesn't run in Windows 8.1

Forum tags: 

I installed the beta version (1.9.2) and whenever I hit double click on BleachBit it can't run and it promp the next message:

Errors occurred
See the log file "C:\Program Files (x86)\BleachBit\BleachBit.exe.log" for details

I tried uninstalling and installing again
The one way it runs is when I hit on Shred with BleachBit.

[Note from Andrew: I edited this post to correct 0.9.2 to 1.9.2]

Hi William,

Thank you for the bug report. I assume you mean 1.9.2 beta, which was recently released.

It would really help to see the contents of that log file. If you navigate to the folder C:\Program Filed (x86)\BleachBit, please double click on it. Then please paste the contents either here or in a bug ticket at . This will help with troubleshooting.


Andrew, lead developer

BleachBit.exe.log says:

Traceback (most recent call last):
File "", line 47, in
File "bleachbit\GUI.pyo", line 850, in __init__
File "bleachbit\Windows.pyo", line 267, in elevate_privileges
File "bleachbit\Windows.pyo", line 541, in parse_windows_build
File "decimal.pyo", line 540, in __new__
File "decimal.pyo", line 3471, in _raise_error
decimal.InvalidOperation: Invalid literal for Decimal: '32bit'

Very helpful. I filed it as bug 1523276.

Andrew, lead developer

Are you running Windows XP, Vista, 7, 8, 8.1, or 10? Is it 32-bit or 64-bit?

Andrew, lead developer

I use Windows 8.1 - 64 bits.

WilliamBE, Thank you for this report. This should be fixed in BleachBit 1.9.3 beta: BleachBit should start on Windows without the error Invalid literal for Decimal: '32bit'.

Andrew, lead developer

Thanks to you. I proved this new beta version 1.9.3 and works nicely and it just have two issues related to what you posted:
The line "platform.version" says: 32bit.
Bleachbit No UAC doesn't run on my PC.
Thanks again!

The 32bit instead of a build number like 10.0.10240 is what was causing the startup problems in 1.9.2 beta. It happened on two users' systems, but I could not reproduce it. This helps confirm the problem, which I solved by getting the version number another way. So now I will consider the 32bit harmless.

Hmm, what happens when you try to start the shortcut BleachBit No UAC? Is there an error message of any kind?

Andrew, lead developer

When I try BleachBit No UAC, doesn't show anything. Just the cursor's blue circle loading one second and nothing else happens.

WilliamBE, the No UAC is fixed for the next release. Thank you for reporting it.

Andrew, lead developer

Thanks to you! I'll be alert in case of new issues :)

Andrew, lead developer

Thank you. I tested it and everything is OK. It works perfect for me now.