In Windows 7 always an error with one file

Forums: 
Forum tags: 

I am using BB 1.4 in Windows 7 Ultimate and there is a single object (file?) which generates an error.

This is the log entry.

Traceback (most recent call last):
File "bleachbit\Worker.pyo", line 82, in execute
File "bleachbit\Command.pyo", line 85, in execute
File "bleachbit\Windows.pyo", line 127, in delete_locked_file
error: (5, 'MoveFileEx', 'Access is denied.') <------------------------

Thank you for the helpful traceback. Two more pieces of information would help a lot towards solving the problem.

1. Are you running BleachBit with administrator privileges? The best way to check is to click Help - System Information. Please report the value for win32com.shell.shell.IsUserAnAdmin().

2. Can you narrow it down to a single option or file? To try individual options, right click on them in the tree view (on the left side of the screen). This lets you run the clean command without unchecking all the other options.

---
Andrew, lead developer

ineuw's picture

Being the only user, I have full Admin rights, I gave full rights to everything and everyone, to make my life easy. I checked Bleachbit as well, both Bleachbit.exe and the shortcut I use to activate it, I have full rights.

I didn't find win32com.shell.shell.IsUserAnAdmin() anywhere in the System Information.

The error is in the System section Temporary files and this is the screen report when I ran it individually.

Mark for deletion 16.4kB C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache\4efb409cba728e5c8b8fb59296463130_fce8395c8fd8a86e_6229ccd76215aea1_0_0.bin
Mark for deletion 4.1kB C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache\4efb409cba728e5c8b8fb59296463130_fce8395c8fd8a86e_6229ccd76215aea1_0_0.toc
Delete 16.4kB C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache\4efb409cba728e5c8b8fb59296463130_fce8395c8fd8a86e_e421b2758c6ffad8_0_0.bin
Delete 4.1kB C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache\4efb409cba728e5c8b8fb59296463130_fce8395c8fd8a86e_e421b2758c6ffad8_0_0.toc
Delete 1MB C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache\4efb409cba728e5c8b8fb59296463130_fce8395c8fd8a86e_e421b2758c6ffad8_0_1.bin
Delete 0 C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation\NV_Cache
Delete 0 C:\Users\ineuw\Local Settings\Temp\NVIDIA Corporation
Mark for deletion 0 C:\Users\ineuw\Local Settings\Temp\FXSAPIDebugLogFile.txt
(5, 'MoveFileEx', 'Access is denied.')
Delete 0 C:\Windows\temp\_avast_
Mark for deletion 0 C:\Windows\temp\FXSAPIDebugLogFile.txt
Mark for deletion 0 C:\Windows\temp\FXSTIFFDebugLogFile.txt
Disk space recovered: 1.1MB
Files deleted: 11
Errors: 1

This was the screen output when I ran it the 2nd time

Mark for deletion 0 C:\Users\ineuw\Local Settings\Temp\FXSAPIDebugLogFile.txt
(5, 'MoveFileEx', 'Access is denied.')

The error in the log file is always the same

Linux Mint Cinnamon 20. 0 64bit

ROCKNROLLKID's picture

(5, 'MoveFileEx', 'Access is denied.') is usually on files that BleachBit cannot delete because either the file is locked, like certain system files, or the file is currently in use and cannot be accessed, like if you keep Firefox opened when deleting Firefox history. There really isn't much that can be done with these files. You could try deleting the files manually and see if that works.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

ineuw's picture

I thought of the same thing. It looks like they are related to Nvidia. Just thought you might want to know. But then I saw on the web that this is an issue reported way back. so I am not worried about it. Thanks for your guidance.

Linux Mint Cinnamon 20. 0 64bit

Hmm. In this case BleachBit tried to delete the file normally, and it failed. This is normal when another process has the file open.

Then it fell back to a special Windows process that deletes the file on the next boot ("MoveFileEx"), and this failed too.

This is a screenshot showing the IsUserAnAdmin status

---
Andrew, lead developer