Unable to clean the "user" account

Forums: 
Forum tags: 

I'm running Debian 8 (Jessie), and Bleachbit 1.4. I can click on "as root", and the screen comes up asking for the root password. I put in the root password, the bleachbit screen comes up, I make my selections, and everything works fine for the root account. But if I click on the bleachbit icon to run bleachbit on the user account, I get nothing. when I click on the "as root" icon, and choose "ignore", I get nothing. If I open a terminal and execute "bleachbit", I get:

Gtk-Message: Failed to load module "canberra-gtk-module"
info: starting BleachBit version 1.4
Traceback (most recent call last):
File "/usr/bin/bleachbit", line 43, in
import bleachbit.GUI
File "/usr/share/bleachbit/bleachbit/GUI.py", line 40, in
from Cleaner import backends, register_cleaners
File "/usr/share/bleachbit/bleachbit/Cleaner.py", line 40, in
import Special
File "/usr/share/bleachbit/bleachbit/Special.py", line 27, in
from Options import options
File "/usr/share/bleachbit/bleachbit/Options.py", line 297, in
options = Options()
File "/usr/share/bleachbit/bleachbit/Options.py", line 65, in __init__
self.restore()
File "/usr/share/bleachbit/bleachbit/Options.py", line 194, in restore
self.set_list('shred_drives', guess_overwrite_paths())
File "/usr/share/bleachbit/bleachbit/Options.py", line 241, in set_list
self.__flush()
File "/usr/share/bleachbit/bleachbit/Options.py", line 74, in __flush
_file = open(Common.options_file, 'wb')
IOError: [Errno 13] Permission denied: '/home/stevetech/.config/bleachbit/bleachbit.ini'

I tried upgrading to version 1.12, and I get the same results. Any suggestions?

Thanks for your help.

stevetech

It seems the root user owns your personal configuration file, so try this command
sudo chown -R stevetech ~/.config/bleachbit

Let me know how it goes

---
Andrew, lead developer

That worked great!!!

Thanks