starting Bleachbit with Windows


I have a strange problem: I have installed Bleachbit succesfully on several laptops, made a shortcut of the console.exe and placed it in the startup folder. Works like a charm!

Now, on another laptop I did the same thing but everytime Windows starts it opens the dialogue if I want to run the program and clicking OK it opens the standard gui of Bleachbit?

I want Bleachbit to silently clean when starting the laptop.
I run the latest version of Windows 10 and also the latest Bleachbit, I tried both the portable and install versions.

BleachBit version: 
Your operating system: 
Windows 10 Corporate Edition

I hear you did the same thing on a few laptops, and it works on some but not on others. What happens if you add --no-uac to the command line options?

(By the way, I couldn't see your message until, as an administrator, I edited it and moved the text from "summary" to "body." Just FYI, for the next time you post.)

Andrew, lead developer

In the console shortcut I added:

--no-uac --clean

It does start correctly now but does not clean anything.

Did you add options such as google_chrome.cache? Please see also the documentation about the command line interface

Andrew, lead developer

I added several options in the gui. I even tried to add the --preset option but no success.

Could the reason be that the laptop where it does not work has an AMD cpu?

I got it working: I used the newest beta version and added the commands: --no-uac --clean --preset
Works as it should, I wonder what is different in the newer beta version?

I am not sure why it didn't work, but I am glad you got it working.

I don't think it's the CPU. If you could start the graphical interface for BleachBit, the command line interface should work too. BleachBit should work just as well on Intel, AMD, and other CPUs.

Andrew, lead developer

I was was using version 4.0.0 on my Windows 10 desk top and getting "OSError: [Errno 22] Invalid argument: 'C:\ . . ." , when trying the wipe free disk space option. On the GitHub help forum it was advised to try/test the 4.10 beta version which solved the problem and seemed to work well without glitches. I did not try All the options though.