My options does not saving

Forums: 
Forum tags: 

Hi,

I use BleachBit 0.9.3. It works perfect. I newly start to use winapp2.ini. I download it automatically from the settings of BleachBit. But something goes wrong:

The "Utilities" group (which is coming with winapp2.ini) makes itself unselected after each restart BleachBit.

I reset all the settings of BleachBit (and I also re-install it) but did not change anything.

I think it is a simple bug.

Utilities group has inside:
---
7-Zip More
AMD/ATI
Avira More
jv16 PowerTools Registry Compact Backups
TuneUp Utilities 2011/2012 Reg Defrag Cleanup
VirtualBox logs
Windows Defender Definition Updates
---

Thank you

(New Note: This issue exist on the 0.9.4-stable version.)

Your description is usful and troubleshooting steps are a good idea.

I tried reproducing this with BleachBit version 0.9.4, and it works OK here on Windows XP. Also I reviewed a little of what is going on under the hood, and I don't see a likely cause.

A few questions

  1. Does the whole utilities group become unselected?
  2. What if you select one item under utilities (such as 7-zip more)?
  3. Do the selections of other groups (such as Firefox) remain after restarting Bleachbit?

---
Andrew, lead developer

1 - Yes whole become unslected.
2 - Whole grupup becaome unselected.
3 - I dont understand the question.

Simply I can say that: After restart the BleachBit, just Utilities groups makes itself unselected. Other groups does not have any problem.

Would you please email me two pieces of information? My email address is the link on the bottom center of every page on this site: just click my name.

The two pieces of information are

1. In BleachBit click Help - System Information, click copy, and paste this into the email.

2. In that information there is a line that starts with options_dir. Please open that directory and attach the file bleachbit.ini to the email. If you need more help with this step, please let me know

---
Andrew, lead developer

Could not find your email:

1-

BleachBit version 0.9.4
GTK version 2.16.6
local_cleaners_dir = C:\Users\sema\Desktop\cleaners
locale_dir = C:\Users\sema\Desktop\BleachBit-Portable\share\locale\
options_dir = C:\Users\sema\Desktop\BleachBit-Portable
personal_cleaners_dir = C:\Users\sema\Desktop\BleachBit-Portable\cleaners
system_cleaners_dir = C:\Users\sema\Desktop\BleachBit-Portable\share\cleaners\
locale.getdefaultlocale = ('tr_TR', 'cp1254')
os.getenv('APPDATA') = C:\Users\sema\AppData\Roaming
os.getenv('localappdata') = C:\Users\sema\AppData\Local
os.getenv('USERPROFILE') = C:\Users\sema
os.expanduser('~') = C:\Users\sema
platform.win32_ver[1]() = 6.1.7601
platform.platform = Windows-32bit-SP1
sys.argv = ['C:\\Users\\sema\\Desktop\\BleachBit-Portable\\bleachbit.exe']
sys.executable = C:\Users\sema\Desktop\BleachBit-Portable\bleachbit.exe
sys.version = 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
win32com.shell.shell.IsUserAnAdmin() = True
__file__ = C:\Users\sema\Desktop\BleachBit-Portable\library.zip\bleachbit\Diagnostic.pyo

2-

https://gist.github.com/4358845

I think I understand the bug. Your system is in Turkish, and the group name "Utilities" is stored translated "araçlar" in bleachbit.ini.

I filed this as bug 1093134 for fix in the next release.

---
Andrew, lead developer

The fix is ready for testing in BleachBit 0.9.5 beta. Let me know how it goes

---
Andrew, lead developer

Problem fixed on beta version. Thank you :)