[BUG] BleachBit Errors Occurred:

Forums: 
Forum tags: 

Recently tried using BleachBit 0.8.7 Portable (PortableApps & BleachBit versions)
I installed BleachBit 0.8.7 on my USB Flash. I attempted to start BleachBit, the PortableApps Dev splash screen appeared and then I was given this error:

'Errors occurred:

See the logfile
'G\XMAIN\PortableApps\BleachBit\BleachBit.exe.log' for details

BleachBit.exe.log:

Traceback (most recent call last):
File "bleachbit.py", line 42, in
File "bleachbit\GUI.pyo", line 37, in
File "bleachbit\Common.pyo", line 135, in
pywintypes.com_error: (-2147467259, 'Unspecified error', None, None)'

I was not prompted with UAC before the error was given. Just thought I should mention that.

I then tried the official BleachBit 0.8.7 Portable and was given the same error (Just without the PA splash)
After that I tried to install BleachBit 0.8.7 locally and was also given the same error.

I was wondering what was wrong so, I decided to try an older version. The last 0.7.x stable release (0.7.4)
0.7.4 installed locally without any problems. Afterwards I uninstalled it using Revo Uninstaller.
For those unfamiliar with Revo, its runs the original uninstaller first then searches for file/folders and left behind registry entries.
Revo did not detect anything left behind except for a config file in Appdata. I then ran CCleaner and its registry cleaner.
I manually searched my computer for left anything left behind. ProgramFiles, ProgramData, Appdata, HKEYCU, HKEYLM and environment variables and didn't find anything.
Restarted my computer.

I attempted to install BleachBit 0.8.7 again and it worked. No error. I have no idea why.
Was it searching for something that should have been there and wasn't?

Reproducible?: No
Windows Vista 32bit
BleachBit 0.8.7

You can find the discussion I had with the dev making the PortableApps version here:
http://portableapps.com/node/23746#comment-169854

The line of code from the traceback you posted relates to finding the path for the bleachbit.lnk in the startup folder. Please check these things

1. Is there a link to BleachBit in the startup folder? On Windows XP, this is something like c:\documents and settings\username\programs\startup., You can also see this folder in the Windows start menu.

2. In BleachBit click Help - System Information, copy it, and please paste it here in the forum. If you think this is very private, use the direct email at the very bottom of this page.

---
Andrew, lead developer

I removed these folders:
C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
C:\Users\Admin\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\StartUp
C:\Users\Default\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\StartUp
And still can't reproduce the error.

I found these folders under my Appdata after a local install:
C:\Users\Admin\AppData\Roaming\BleachBit
C:\Users\Admin\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\StartUp\BleachBit

System information:
BleachBit version 0.8.7
GTK version 2.16.6
local_cleaners_dir = C:\Program Files\cleaners
locale_dir = C:\Program Files\BleachBit\share\locale\
options_dir = C:\Users\Admin\AppData\Roaming\BleachBit
personal_cleaners_dir = C:\Users\Admin\AppData\Roaming\BleachBit\cleaners
system_cleaners_dir = C:\Program Files\BleachBit\share\cleaners\
locale.getdefaultlocale = ('en_US', 'cp1252')
os.getenv('APPDATA') = C:\Users\Admin\AppData\Roaming
os.getenv('localappdata') = C:\Users\Admin\AppData\Local
os.getenv('USERPROFILE') = C:\Users\Admin
os.expanduser('~') = C:\Users\Admin
platform.win32_ver[1]() = 6.0.6002
platform.platform = Windows-Vista-6.0.6002-SP2
sys.argv = ['C:\\Program Files\\BleachBit\\bleachbit.exe']
sys.executable = C:\Program Files\BleachBit\bleachbit.exe
sys.version = 2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
win32com.shell.shell.IsUserAnAdmin() = True
__file__ = C:\Program Files\BleachBit\library.zip\bleachbit\Diagnostic.pyo
running process: alg.exe
running process: audiodg.exe
running process: avastsvc.exe
running process: avastui.exe
running process: bleachbit.exe
running process: chrome.exe
running process: csrss.exe
running process: dwm.exe
running process: explorer.exe
running process: lsass.exe
running process: lsm.exe
running process: mobsync.exe
running process: nvvsvc.exe
running process: rundll32.exe
running process: services.exe
running process: slsvc.exe
running process: smss.exe
running process: spoolsv.exe
running process: svchost.exe
running process: system
running process: system idle process
running process: taskeng.exe
running process: viewpointservice.exe
running process: wininit.exe
running process: winlogon.exe
running process: wlanext.exe
running process: wmic.exe
running process: wmiprvse.exe
running process: wmpnscfg.exe
running process: xaudio.exe

It looks like your system is a fairly-normal English Windows Vista. Someone else once reported the same "pywintypes.com_error: (-2147467259,'Unspecified error'" error on Windows 7, and like your situation, it works fine now. Which antivirus software do you use? Maybe the antivirus software initially blocked BleachBit's attempt to access this Windows API? From the process list, it looks like Avast? What if you answer no to the UAC (permission to run as administrator)?

---
Andrew, lead developer

I use Avast anti-virus.
I just booted my computer and deleted the contents of my windows folder in;
C:\Users\Admin\AppData\Roaming\Microsoft\Windows

It contained 'Recent' and 'Start Menu' folders.
After that I tried to start BleachBit and I was given the exact same error message.

I tested it to see what folder it wanted by creating Start Menu -> Programs -> StartUp
I was given the same error until I recreated StartUp again.

Like I thought, I was a missing file/folder on my side.
What I don't understand is why it gave me the error in 0.8.7 but not 0.7.4 Did 0.7.4 not work with the StartUp folder?

I think it should check if the folder exists first and find some way to handle it if it doesn't.
In the very rare chance that the folder doesn't exist it needs to know what it do.

The only way I see that folder getting deleted is if the user does it manually or the user runs something like an empty folder cleaner.
(I probably deleted it myself and forgot.)

Sorry for all the confusion. At least in the end we figured out what caused it.

I guess when I deleted that folder before I needed to restart my computer, thats why it didn't error on me.

I think this board is the proper place to ask you about the activation proccess. My link is not working properly, do you know why it is happening? http://bleachbit.sourceforge.net/?0150e9bdbc0dd3e19f8c6210a08,

You mean user account activation? You should start a new topic or forward the email to me. My email address is at the footer (bottom of every page): click on my name

---
Andrew, lead developer

2011-08-24_11-15-37 -> ca0c16709c7ac170ed73e3def0eef3e1 :: a3a266afb5932adb8df8d78ee19 http://bleachbit.sourceforge.net/?a3a266afb5932adb8df8d78ee19,