BitDefender, sqlite and version 0.8.0

Forums: 
Forum tags: 

I downloaded the 0.8.0 windows executable and it wouldn't install at all. A dos window opened and closed but installation didn't proceed. I did this twice with the same result on two different computers.
I downloaded the zipped version and installation was OK on both computers, except that I got the same message on both: "Error loading the SQLite module: the antivirus software may be blocking it." I couldn't find any evidence that BitDefender was blocking it nor a way of preventing it blocking it. (However, this doesn't mean that it is not happening.)
Both computers are Windows XP. 3GB memory, running BitDefender. I used the new white list to exclude the BitDefender program and docs and settings folders.
Both computers scanned OK but reported errors in relation to sqlite files.
This sounds like a similar problem that I reported on another forum topic for the previous version. I downloaded the alternative sqlite3.dll from http://sqlite.org/sqlitedll-3_6_23_1.zip as advised and the errors went away, although obviously the installation issue still exists.
Do you concur?
Regards, Graham

Try downloading again now. I just uploaded a new BleachBit 0.8.0 installer. Thanks for reporting this, and sorry for the confusion.

When the SQLite error is happening, does it prevent you from vacuuming Firefox?

---
Andrew, lead developer

New installer works. Sqlite error still reported.
Yes. 10 errors reported if firefox vacuum is the only item selected.
If I substitute the alternative sqlite3.dll as you suggested all errors go away.
Regards, Graham

Do you get SQLite errors with this installer?
http://sourceforge.net/projects/bleachbit/files/bleachbit/0.8.0/BleachBi...

It doesn't "strip debug symbols" from any executables, so it's a little bit larger.

---
Andrew, lead developer

I tried it. The executable worked but I still got an sqlite error on startup as before and sqlite errors when attempting to delete sqlite items such as firefox vacuum.

I think I fixed it. It does work here with Bit Defender and prevents the two errors:

ImportError: DLL load failed: Invalid access to memory location
Error loading the SQLite module: the antivirus software may be blocking it.

Would you mind trying this one?

http://sourceforge.net/projects/bleachbit/files/bleachbit/0.8.0/BleachBi...

---
Andrew, lead developer

Sorry about the delay in replying. This works fine. No errors at start up and no sqlite errors reported on scan. No need to use special dll file.
Thanks for the effort.
Regards, Graham