0.8.3 hangs when attempting to clean Chromium

Forums: 
Forum tags: 

Both in preview and delete modes this happens while vacuuming Chromium (chromium-browser). Bleachbit hangs with "TypeError: run_deep_scan() takes no arguments (1 given)". [p.s. I am running LinuxMint 9 "Isadora"-LXDE, mostly based on Lubuntu 10.04 "Lucid".]

debug: clean_operation('deepscan'), options = '[u'ds_store', u'backup', u'tmp', u'thumbs_db']'
debug: clean_operation('firefox'), options = '['cache', 'cookies', 'dom', 'download_history', 'forms', 'passwords', 'places', 'session_restore', 'url_history', 'vacuum']'
debug: clean_operation('thumbnails'), options = '[u'cache']'
debug: clean_operation('adobe_reader'), options = '[u'cache', u'mru', u'tmp']'
debug: clean_operation('vlc'), options = '[u'mru']'
debug: clean_operation('flash'), options = '[u'cache', u'cookies']'
debug: clean_operation('thunderbird'), options = '[u'cache', u'cookies', u'passwords', u'vacuum']'
debug: clean_operation('system'), options = '['desktop_entry', 'cache', 'clipboard', 'recent_documents', 'rotated_logs', 'tmp', 'trash']'
debug: clean_operation('apt'), options = '[u'autoclean', u'autoremove', u'clean']'
debug: clean_operation('notify-osd'), options = '[u'logs']'
debug: clean_operation('syslogs'), options = '[u'acpid', u'apache', u'auth', u'boot', u'bootstrap', u'casper', u'ckit', u'cron', u'daemon', u'debug', u'dkms', u'dmesg', u'dpkg', u'fcfg', u'kern', u'lastlog', u'mail', u'messages', u'popcon', u'preload', u'pyctl', u'sec', u'syslog', u'term', u'udev', u'user', u'vbox', u'xorg']'
debug: clean_operation('x11'), options = '[u'debug_logs']'
debug: clean_operation('java'), options = '[u'cache']'
debug: clean_operation('chromium'), options = '[u'cache', u'vacuum']'
Traceback (most recent call last):
File "/usr/share/bleachbit/Worker.py", line 198, in run
self.run_deep_scan()
TypeError: run_deep_scan() takes no arguments (1 given)

same under windows xp

Traceback (most recent call last):
File "bleachbit\Worker.pyo", line 198, in run
TypeError: run_deep_scan() takes no arguments (1 given)

Thank you for this report. I fixed this for the next release, but for now you may try to

1. to disable all the deep scan options including backup files, ds_store, thumbs.db, and temporary files
2. to downgrade to an older version such as 0.8.2 or 0.8.1

---
Andrew, lead developer