Won't clean normal user

Forums: 
Forum tags: 

Vista Home Premium on Gateway M-6827. I can clean as Administrator but not as normal user. Have tried extensively to work around including shift+right click+administrator in normal user which only cleans administrator. How to clean normal user in normal user or Administrator? -Thanks!

Are you using BleachBit version 0.7.4? Portable or regular? When you start BleachBit, does Vista show you the UAC (User Account Control, aka "accept or deny") dialog asking whether you want to run as administrator? By administrator, do you mean administrator privileges or the administrator user account? Is there an error message? If so, please include the error message verbatim.

---
Andrew, lead developer

I've tried both installed version 0.7.3 and portable 0.7.4. No UAC dialog appears and have tried running BleachBit with UAC off. Have tried through administrator privileges in normal user, in an administrator account and in vista's "secret" administrator account. No problems running in the last two yet this only cleans the administrator accounts. In normal user both BleachBit versions "stall" if you will and bleachbit.exe will not open and the curser continually blinks. In bleachbit_console a series of cascading command prompts continually opens and closes and I must reboot to get out of both exe and console versions. Absolutely no error messages.

I'm having this problem as well. My admin account is nice and clean, but I do everything with my user account so this doesn't help me too much.

This thread is a year old now, and so BleachBit version 0.8.7 is the latest (though not for long). Please try a newer version.

What do the "cascading prompts" say? Have you tried disabling the antivirus software or putting it into game mode? Which antivirus software do you use? Can you check the Application log in the Windows Event Viewer for any errors during the time you run BleachBit? To see the Windows log, hold the Windows key while pressing the letter R, type the command eventvwr, and press the ENTER key.

---
Andrew, lead developer

Thought I should mention that I'm seeing this problem on 0.8.7

I also thought I should elaborate a little on what I'm seeing since this issue doesn't appear to have much attention on it.

Using Windows Vista 64bit Ultimate

Let's say I log into my normal user account "Carl" and run BleachBit. The program immediately asks for my admin account password so Bleachbit will have the proper permissions to work it's magic. But once I authorize as my admin account "Root" BleachBit only sees me as being "Root" and no longer as "Carl"

So when doing a clean it goes through:
C:\Users\Root\Application Data\...

and ignores:
C:\Users\Carl\Application Data\...

The problem is I use my "Carl" account for everything so that's where all the clutter is. This severely reduces the effectiveness of the software and I have not found any sort of workaround for this.

This was my original post and I am using 0.8.7 now as well. What I did notice in my 32 bit Vista Business SP2 is that when cleaning, clean once in "normal user" by right clicking BleachBit and "Run as Administrator" to clean admin, and then run BleachBit again by simply left clicking bleachbit.exe without admin privileges and although a prompt will come up, wait a moment and BleachBit should run anyway then x out of the prompt which it then cleans "normal User". In combination with Cleaner this is very effective. Carl I hope this helps.

"In combination with *Ccleaner* this is very effective." (These typos have a life of their own - lol)

And Andrew I'm sorry I can't answer any longer other than the prompts were too fast to read, using Avira Free without game mode. It has been so long now that after reinstalling both the OS, BleachBit and just using an admin account, the issue was resolved before you posted. Carl It occurs to me now that what I previously explained with the two versions of cleaning only works if the "normal user" is actually one of the administrators jumping through the prompt hoops. Having to type in an admin password I don't believe (try it though) will allow the "two version" method to work. Elevating your "Carl" account obviously defeats the purpose. A procedure for temporarily bypassing the User Account Control (UAC) with a desktop (or hidden) shortcut to only run a single application for a real normal user is quite expertly outlined at this site:
http://www.petri.co.il/bypass-uac-using-desktop-shortcut.htm#

I tried your suggestion and it worked. When the prompt came up for the admin password I just hit escape and BleachBit started as usual and let me clean my own account. Freed up about 3-4 gigs.

Thanks for your help!

You posted while I was writing. I'm glad the simple solution worked. 3 - 4 GB times days, months... Thread solved !

I looked into this. Vista user accounts can be a "Standard user" or an "Administrator." The current BleachBit (version 0.8.7 and 0.8.8) assumes you are an administrator: in this case, answering yes does not require a password and does not change the user context, so you are still cleaning the same profile. The elevated privileges allow BleachBit to clean a few extra files such as Windows logs, and without the permissions, you may see "permission denied" or the files may not even preview.

if you are a standard user, the prompt requires a password and changes the user context, so it cleans a different profile. For a standard user, the prompt looks like this:

User Account Control
An unidentified program wants to access your computer
Don't run the program unless you know where it's from or you've used it before
bleachbit.exe
Unidentified publisher
To continue, type an administrator password, and then click OK.
User Account Control helps stop unauthorized changes to your computer.

One workaround, as you discovered, is to click CANCEL. For the future I've logged bug 797181 to not ask standard users for elevated privileges.

---
Andrew, lead developer

Excellent Andrew - there sure has been a lot of thought put into BleachBit and it has never "broken" anything in my Ubuntu. One of the few cross platform apps.