Unremovable folder after trying to "Wipe Free Space"

Forums: 
Forum tags: 

First I would like to thank you for a great yet simple to use application.

Now to solving an issue.

I tried to run "Wipe Free Space" on one of my hard drive partitions (271 GB) in Linux (Mint 16 Cinnamon). It progressed fine until a certain point (about 80% of the way) then stopped. I tried again and the same thing happened.

After the attempts I found two folder in the partition root with weird names and weird behaviour.
1. I can enter the folder, but it won't list any files, although the cursor shows that it keeps scanning for files.
2. I tried deleting the folders with the following methods:
* Via Nemo file manager,
* Using 'rm -Rf ' command and even tried to shred the,
* With Bleachbit

The first two methods would do nothing. On the other hand, Bleachbit would run forever, listing strange filenames and folder, and even when it shows "Done" in the progress bar, it would continue to list files and never get to actually deleting the folders.

Any suggestions?

This folder may have many, many (small) files which explain some of this behavior.

Have you tried rebooting the operating system or unmounting the file system?

When you run the rm command, specify the folder without wildcards like sudo rm -rf /folder instead of sudo rm -rf /folder/*

Let me know how it goes, and I will work on improving the "wipe free disk space" for a future release.

---
Andrew, lead developer

No Go!

The folders are still there.

What happens when you try? If there is an error message, please copy it verbatim.

Which file system are you using (ext3, ext4, btrfs)? If you are not sure, run df -T /folder where /folder is the path of the folder with the problem.

I just did a test with ext4 and Linux 3.11 (Ubuntu 13.10). I created a 1GB partition and ran BleachBit until it made about 61K empty files, which exhausted the inodes. Then I was able to count them like this
ls -lah /tmp/ext4.mount/rkmOODvbML/ | wc -l

And delete them like this sudo rm -rf /tmp/ext4.mount/rkmOODvbML

---
Andrew, lead developer

I was able to delete one of the directories using the rm command. The other one is still there.

As for your questions:

  1. The files system is ext4
  2. Running the ls command as instructed give me the following result:
    ls: cannot access /media/docs/CBDgtQ77L: No such file or directory
    0
  3. Running
    sudo rm -rf return immediately to prompt withour any visible results.
    Even running
    sudo rm -rfv
    goes back to the prompt immediately without any output.
  4. Any other suggestions on how to remove this stubborn directory?

    Thanks.

Sorry if these are dumb questions :), but

#1 Are you sure the directory is there and called /media/docs/CBDgtQ77L ? Maybe it is called something else. In my experience "No such file or directory" means what it reads.

#2. Are you passing the path to rm like sudo rm -rfv /media/docs/CBDgtQ77L

---
Andrew, lead developer

To answer your questions, here is the sequence of commands I ran in my terminal.

Any other suggestions?


ronen@ronen-vostro ~ $ ls /media/docs
CBDgtQ77L Documents Downloads lost+found Music Pictures Videos
ronen@ronen-vostro ~ $ ls -lah /media/docs/CBDgtQ77L | wc -lls: cannot access /media/docs/CBDgtQ77L: No such file or directory
0
ronen@ronen-vostro ~ $ sudo rm -rfv /media/docs/CBDgtQ77L
[sudo] password for ronen:
ronen@ronen-vostro ~ $ ls /media/docs
CBDgtQ77L Documents Downloads lost+found Music Pictures Videos
ronen@ronen-vostro ~ $

Did this work?

I am having the same issue where I was able to delete the long obfuscated file but unable to delete or ls the directory that bleachbit left behind

I have tried issuing rm -rf stupiddirname/ with no luck... it just hangs

I cannot ls the directory as well

I cannot open the directory or shift + delete in thunar

It didn't work for me.

I got rid of that folder only when I made a clean install of my Linux Mint

that sucks... i am going to find a logical explanation to this and refuse to surrender my box to bleachbit >.<

ext3/ext4 are slow at deleting many empty files, so while it may appear to hang, it is probably working. You can verify it is deleting files by watching the inode count change
df -i foldername

---
Andrew, lead developer

Thanks Andrew, I let the rm -rf run overnight and it did remove the directory. I wish I would have used the time command so I could see exactly how long it took. Sorry for the frustration :)

Try logging in as root. Go to Administration>Login Window>Options then select Allow root login. Logout of your current session. Login by typing "root" without the quotation marks hit enter and key in your password. When you login you will find the files that bleach bit made right on the home folder. You will be able to delete them instantly. I tried this on Linux mint 17.1 Cinnamon and it worked. On top of each window is the words "Elevated privileges" highlighted in red. This means you have full administration access (root access). To be on the safe side if you are not an advanced Linux user, it is best to lock the root account once again. Go to Menu>Administration>Login Window>Options then deselect the "Allow root login" option. Then logout of your current session or reboot. Login in again with your normal account. If you do not understand why Linux Mint does not allow login in as "root" by default, check the Linux Mint/Ubuntu forum for answers. I hope this helps

After dealing with bugs in Debian KDE I decided to use Xubuntu.
Whenever Debian would not finish bleachbit no strange folders would be created (at least not to my knowledge).
After installing Xubuntu and running bleachbit, I found a strange folder in my home directory.
Going to see if I can login as root and delete the strange folder.

I guess the root account is disabled. I'll leave the computer running and see if the strange folder gets deleted.
The strange filename happened on bleachbit 1.0 (the version that installed when using Xubuntu 14.04) and right now I have bleachbit 1.8 installed. The same strange folder name happens with bleachbit 1.8 also if bleachbit does not finish.

I ended up reinstalling Xubuntu. I might just not use the "free disk space" option from now on.

Please check it is BleachBit version 1.8 by clicking Help - About.

Since BleachBit version 1.2, the folder is located by default in ~/.cache instead of ~/. You can change this preference by either deleting ~/.config/bleachbit/bleachbit.ini (such as by clicking File - Shred Settings and Quit) or by changing the folder under the Preferences menu.

In BleachBit 1.0 the folder could have many thousands of empty files, but since BleachBit 1.2 it will have only a few, large files. In both cases the folder names and file names will have strange names.

Linux is slow deleting thousands of files, so much that it can seem like it is not doing anything, so you really should not see this since BleachBit version 1.2.

As you indicated, it may be a good idea to avoid the "wipe free disk space" option unless you really need it.

---
Andrew, lead developer

Working great with remove free disk option unchecked. Thanks again!

ROCKNROLLKID's picture

Might I suggest, for future reference, to use the "Add new comment" feature on the forums to prevent your posts from shrinking. Just figure I would let you guys know that.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).