Shred with bleachbit


Hi to all,
after installing the latest update whenever I double click on a folder bleachbit opens and asks to delete the folder, how can I prevent this from happening?
The shred with bleachbit option is right on the top in black bold on my right click options.
I really like bleachbit but I've had to unistall it due to these reasons, I tried to search the forums for some help and was unable to find anything.
Any solution to this would be very helpful thanks, Xyru.

Which version of Windows (XP, Vista, 7, 8, etc.)?

When you right click, is any of the options "Open"?

After uninstalling, does it work normally?

As a temporary workaround, what do you think about manually editing your registry (with some instructions)?

Andrew, lead developer

Hi, Im using Windows Vista Premium

I see the open option but whenever I double click on a folder it opens bleachbit up and asks me to delete the folder and item.

Im willing to edit my registry, if you could also tell me how to reverse it if not necessary at a certain point.

You can delete the shred integration by deleting HCKR\AllFileSystemObjects\shell\shred.bleachbit. To get it back, re-installing is easiest, or you can get it back by exporting the key before deleting it and then re-importing it.

Because so many people have downloaded BleachBit 1.0 and used it without this problem, I am wondering if there is some kind of bad interaction ("allergy) with other unique software on your system.

Do you use any software that edits or cleans the registry?

Do you use any other software that would register a command for folders or for any kind of files?

Andrew, lead developer

I occasionally use ccleaner and glary utilities 4 pro. I do not see anything bleachbit related in the registry location which is really weird.

Also Im having to use a proxy to login, otherwise it shows me a blank page? whats going on?

Assuming BleachBit 1.0 is installed, it is strange you are not seeing anything there. Within the registry program, you could try doing a registry search for the string "Shred with BleachBit" (the label on the context menu) or for "bleachbit.exe" or "--shred.exe" (the command line option). All of these searches are without the quotation marks.

Do you have any special security software that would stop a program from writing to the registry? Or redirect its changes, so they were written somewhere else?

You mean you cannot login to the forum with using an HTTP proxy? Have you tried booting your browser into safe mode, disabling plugins, or using another browser on your system? Exactly when do you see the blank page---is it after typing in your username and password? Which web browser? Do you use any special network software like Tor?

Andrew, lead developer

Hi, i don't have a problem with logging in as yesterday so its fine, as for the looking anything bleachbit related I could not find anything in regedit.

A patch has landed that makes this integration optional during installation, and it will be released in the next beta version after BleachBit 1.0.

Andrew, lead developer

This happens also with BB 1.4. + vista business 64bit + previous ccleaner used on he system. Did you/somebody find any solution? Thank you.

Hi I downloaded the recent beta and I unclicked integration shred and the problem seems to have stopped now.
I can finally use the most updated version, thanks alot for your help.

Sinds version 1 I have the same problem but only on the dutch version of Vista & W7, not on the english version. I install and maintain a lot of pc's and saw this behaviour on multiple ones. Unticking the 'Shred with Bleachbit'-option during installation solves the problem, as did removing the registry keys mentioned above. But it remaines a dangerous option for someone who doesn't know it.
It seem to occur only on subfolders of My Documents, My Pictures, My Music, Desktop, etc. but not always. Making a new subsubfolder inside the subfolder will sometimes change the default action of the subfolder, but not always. Hope this will be solved in the next version, so a standard installation can just be next-next-next-ready! :-)