Particular problem with bleachbit

Forums: 

Hi Andrew, when i run bleachbit not as a root and i try to clean, i have a lot of stuff cleaned in the GUI interface, but when i run bleachbit as root the programm clean less stuff, usually it shows me up this:
apt-get autoclean 0
apt-get autoremove 0
Clipboard 0

Disk space recovered: 0
Files deleted: 0
Special operations: 3

Only this.

When i had my sistem outdated bleachbit as root came also with the TERMINAL and cleaned so much more stuff, but now that i have updated my sistem , when i run bleachbit as root it cleans more or less only the stuff that i have showned you above.
I wonder if it is normal, or not

ROCKNROLLKID's picture

On Windows, if you run BleachBit as non-admin, it will not clean as many files because some files require admin rights to be cleaned, such as system logs, etc. I do not know if the same applies to Linux (assuming you are using Linux because you said terminal).

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Are you asking why it is not cleaning your web browser, for example?

Depending on your Linux distribution, how you installed BleachBit, and how you start BleachBit, when you start BleachBit as root (administrator) it may clean the /root context instead of the unprivileged user (/home/whoever).

You can check which is happening by clicking Help - System Information and look for this line

os.path.expanduser('~') = /home/username
os.path.expanduser('~') = /root

If it looks like the first example, then it is cleaning the unprivileged account, and if you see the second, it is cleaning the privileged account.

In other words, you may need to run as root to clean system files such as APT and system logs, and then you may need to run again as a normal user to clean your web browser and other personal files.

---
Andrew, lead developer