lost files i needed

Forums: 

hi im oon ubuntu 11.04 i used bleachbit to delete stuff for a while it worked great but now it deleted all my virtualbox vms how do i get them back without using photorec

I am sorry to hear about the lost files. In which directory were the lost files stored? Which option do you think deleted them? I use VirtualBox often, but I don't know how BleachBit could accidentally delete VirtualBox files. On Fedora 14 I have VirtualBox 4.0.8, and its settings are in ~/.VirtualBox/, and no cleaning rules match the virtual machines there.

But now that the files are deleted, and assuming you didn't use BleachBit's overwrite (shred) option, you would first want to power down the machine to prevent any software from overwriting the files. Then you need some kind of specialized file recovery software. I have never tried PhotoRec, but based on the description, it won't recover VirtualBox virtual machines because it doesn't know their magic signature. Also, based on the size, it is unlikely they are not fragmented.

Your file system is probably ext3 or ext4, so try a Google search like this: undelete ext3 OR ext4

---
Andrew, lead developer