Exception error while running system

Forums: 

Hi, I'm trying to clean out my mother's old computer using BleachBit (old as in, running Windows 7). There's around 4.5GB of 'crap' waiting to get removed from the System category, which it finds during pre-search, but when running the cleaner, it tells me that some parts of System was skipped due to, and I quote:

''utf8' codec can't decode byte 0xe6 in position 18: invalid continuation byte'

What is this?

BleachBit version: 
2.0
Your operating system: 
Windows 7

This means it choked on a filename with special (non-ASCII) characters. It is interesting this apparently affects cleaning mode but not preview mode.

I would like to fix the problem, and it would help to reproduce the problem here. Perhaps you can narrow it down to a single checkbox and then to a single filename. If you narrow it down to a single checkbox, then you could copy the preview log (with many files) and send it to me by posting it here (via a link to a pastebin because the list will probably be large), by email, or by attachment to a GitHub issue ticket.

It looks just like GH#328, but I am not sure how to reproduce the error.

Click Help then System Information, and look for the line IsUserAnAdmin. Is it true or false?

---
Andrew, lead developer

User is admin (confirmed and already tried running as admin as well before this).

Narrowed it down to temp files. Here's the log:
https://pastebin.com/NxN3iasD

Appreciate your help.

I ran a search on all ~5000 lines in your log file, and none have special characters except the summary at the end that indicates the total is 4.39GB. However, the summary is not a problem.

To confirm: when you do a preview of Temporary Files, there is no error, but when you try to delete the Temporary Files, you get the error?

About the administrator: that is interesting because in the bug report (#328), the user mentioned it happens only when he is not running as administrator.

Could you please try another test? BleachBit has a console version that may have additional details. One way to launch it is to do a Windows search for BleachBit Debugging Terminal (example), or you can run c:\program files (x86)\bleachbit\bleachbit_console.exe .

You know it is working because there will be a black "DOS" window. If it has more information about the error, please the post it verbatim.

---
Andrew, lead developer

Ran the DT as admin and now it gave me a whole different error.

https://pastebin.com/8hPZGpZF
This is the in-program log

https://ibb.co/ftQv3T
Console screen

Just as a measure, I also decided to again run as admin without the terminal, and I get same error, yet this time much faster than before, for some reason.

I fixed it. For a fix (and an explanation) see my comment today at the end of this page: GH#328

---
Andrew, lead developer