Bleachbit on Fedora 19 is extremely slow to load


I have been using Bleachbit for a while on Windows and it is an absolute excellent application for privacy and cleaning up unnecessary files. Recently I installed Fedora 19 on my laptop and decided to give Bleachbit a go and installed the RPM file from this website. I tried launching it and noticed it took a very long time (~30 seconds?) to launch after my system has competely booted. In perspective, Firefox only takes maybe 6 seconds to load. I dont think it's my computer as I have 4GB of ram and a decent HDD.

Could anyone help me regarding this? It's not the end of the world that this is slow on Fedora but it would be nice if it loaded substationally quicker. :)

Worth mentioning I am using Bleachbit 1.0

I'm guessing while trying to figure out which applications are installed, BleachBit came across a directory with a lot of files.

To see what it is doing, open a terminal and run this command
strace -r /usr/bin/bleachbit

The workaround is to clean the directory with the many files. If this doesn't work, let me know.

While running this command, I noticed it isn't optimal (though rarely 30 seconds), so I put speeding this up on the to-do list as bug 1258840.

Andrew, lead developer

Thanks for your fast reply Andrew. I did read this a week ago and tried using the command to see why it's loading slow and the problem is that when I use that command, it scans everything so fat in the terminal I cannot read the directories it's listing. I saw that Firefox and Thunderbird was causing problems but it's not that big of a deal, though I noticed on Ubuntu Bleachbit seems a lot quicker in scanning.

It's still taking over 40 seconds (I timed it one time and I got exactly 52 seconds) but it's fine, it's still great software :) ).

I submitted a bug for the Windows version as well on launchpad.

Thanks for your help


i've been using bleachbit for many years, dating back to the lewinsky scandal, and it was always zip zip fast to load and execute. now i've installed on lubuntu 16.04 and it is painfully slow to load the gui, then painfully slow to load previews (which i've mostly stopped running the preview), and then painfully slow to execute (especially on the Sanders files)

another strange thing it does that it never did before is that it always states the double of files on preview as are actually deleted on execution. if it says it's going to delete 500mb, it only deletes 250, etc.

should i wipe it down with a cloth or something?

- Clinton Transition Team

i ran your command as you suggested above and get this output:

- Clinton Transition Team