Bleachbit 1.2 Only A Few Options? - Now 1.9.2 too...

Forums: 

I'm also having the same problem now 1.2;

https://bugs.launchpad.net/bleachbit/+bug/1258851

What happened to all the other options?

I only have like 4-5 show up too in 1.2 and I thought this would be fixed by now?

thanks

ROCKNROLLKID's picture

We apologize for such a long delay with this issue. Our team has been looking into this issue, but we don't have any leads of what might be causing this to happen.

What OS do you use (windows or linux)?
32-bit or 64-bit?
Has this happen with version before 1.0 (.9.6 and down)?
Do you have any type of HIPS or antivirus that may be blocking contents from BleachBit? If so, then check the quarantine folders for anything related to BleachBit or XML files (XML files are text files in a different format and should contain no such infections).

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Slackware 14.1 x86_64
This started at the 1x versions, 0.9.6 works just fine
Don't run HIPS or AV in Slackware...

All I know is under /usr/share/bleachbit/cleaners/ I can see all the xml files too;

Ahh I was hoping the lastest release was finally going to work, but no such luck...

In 1.4 these are the only options I have now;

Bash
Deep Scan
Firefox
Flash
Gimp
System
Thumbnails
Transmission
Xchat

By the way I saw this problem in other distros too, not just Slack...

Here is the info from 1.4
------------------------------------

BleachBit version 1.4
GTK version 2.24.20
local_cleaners_dir = /usr/share/cleaners
locale_dir = /usr/share/locale/
options_dir = /home/foo/.config/bleachbit
personal_cleaners_dir = /home/foo/.config/bleachbit/cleaners
system_cleaners_dir = /usr/share/bleachbit/cleaners
locale.getdefaultlocale = ('en_US', 'ISO8859-1')
os.getenv('DESKTOP_SESSION') = gnome
os.getenv('LOGNAME') = foo
os.getenv('USER') = foo
os.getenv('SUDO_UID') = None
os.expanduser('~') = /home/foo
platform.linux_distribution() = ('Slackware ', '14.1', '')
platform.platform = Linux-3.16.1-x86_64-Intel-R-_Core-TM-_i7-3610QM_CPU_@_2.30GHz-with-slackware-14.1
sys.argv = ['/usr/bin/bleachbit']
sys.executable = /usr/bin/python
sys.version = 2.7.5 (default, May 29 2013, 02:28:51)
[GCC 4.8.0]
__file__ = /usr/share/bleachbit/Diagnostic.pyc

/usr/share/bleachbit/cleaners shows all these files;

http://dpaste.com/3PB32YD

ROCKNROLLKID's picture

I am not sure what Andrew has accomplished, so far, with this issue. He claimed there is going to be another update to fix some issues that have occurred in 1.4. After that, maybe he can look more into this issue. As far as I know, this issue only occurs in Slackware. I haven't seen this on other Linux operating systems, but I could be wrong. I am not getting this issue under my Windows 7 64-bit. My only advice to you is to stick with .9.6 and just wait until Andrew can find a resolution for this issue. I wish I could do more for you guys.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

I'm sorry you are having this issue, but I still cannot reproduce it, so it is hard to diagnose and fix. If I could remotely connect using Google Chrome Remote Desktop, ssh, teamviewer, or something else similar, it would make troubleshooting much, much easier.

---
Andrew, lead developer

No remote connections to the box....

Let me know what you want to troubleshoot and look for and I can do it...

I'm going to test some other distros in VirtualBox and see what happens...

So the latest version of Bleachbit hasn't been changed to detect what is installed in the system and only show these options, or all options should still be visible, even if you don't have the application installed?

The change in BleachBit 1.0 (from 0.9.6) was to remove the auto-hide option. Before, it was turned on by default.

The cleaners are automatically hidden if there is nothing to clean. You can disable auto-hiding by editing bleachbit/Cleaner.py near line 86 so it always returns False: just take out the for loop. This will show all the cleaners, but they probably won't do anything. Try it and let me know

---
Andrew, lead developer

By the way in Ubuntu's latest release which uses 1.0 I also only see a few options and Firefox is installed by default in Ubuntu and it's not even showing up in 1.0...

This hide option might be nice to make it as a Preference in the GUI so people can enabe/disable there...

Sorry how do I edit this?

def auto_hide(self):
"""Return boolean whether it is OK to automatically hide this
cleaner"""
for (option_id, __name) in self.get_options():
try:
for cmd in self.get_commands(option_id):
for dummy in cmd.execute(False):
return False
for ds in self.get_deep_scan(option_id):
if isinstance(ds, dict):
return False
except:
print 'warning: exception in auto_hide(), cleaner=%s, option=%s' % (self.name, option_id)
traceback.print_exc()
return True

OK, I made a new branch that restores the removed auto-hide option. Assuming you have git installed, please try this

git clone -b missing-options https://github.com/az0/bleachbit.git
cd bleachbit
python bleachbit.py

Then in the preferences menu, please uncheck hide irrelevant cleaners. If this shows more cleaners, verify whether the preview (or delete) do anything for those cleaners. I am worried they will not do anything.

---
Andrew, lead developer

Assuming this is a hide feature, even in 1.4 it's not showing things I have installed.

These I also have installed that do not appear;

Flash
gimp
Transmission

I'll try the git version and report back...

What a Slacker without Git? LOL... :)

Ir crashes when trying to run it;

info: starting BleachBit version 1.5
Traceback (most recent call last):
File "/usr/bin/bleachbit", line 44, in
gui = bleachbit.GUI.GUI()
File "/usr/share/bleachbit/GUI.py", line 781, in __init__
pref = PreferencesDialog(self.window)
TypeError: __init__() takes exactly 3 arguments (2 given)

Oops, I fixed that now. Please git pull and try again.

---
Andrew, lead developer

Ok it works now,...

All the options are back! :)

Does preview or delete on the restored options yield any changes? What I am worried about is deleting and preview will do nothing on all the hidden cleaners.

---
Andrew, lead developer

Restored options, I don't follow you, do you mean all the items that were hidden before that I can now see?

I click Preview and it shows items to delete, then I click the X to clean and everything is cleaned out... So from what I can tell it's doing it's job ok...

Yes, this is what I mean. If a cleaner hidden by auto-hide finds at least one file to preview or clean, this sounds like an existing bug in the auto-hide code. So I need to keep looking for a way to make auto-hide more reliable.

---
Andrew, lead developer

Going back to what you said before;

'The cleaners are automatically hidden if there is nothing to clean'

So in the latest Bleachbit if you don't have a certain application installed or there is nothing to clean, it's not suppose to appear, the name in the left side pane? This is where I'm still confused, I thought we are suppose to see all the cleaners for all the apps BleachBit supports?

Also I'm still not following this last comment;

If a cleaner hidden by auto-hide finds at least one file to preview or clean...

Because in this git version you made it so nothing is hidden, so how can I now have a hidden cleaner? Makes no sense in my mind? Hmm

All I can see is that everything appears to be working as normal like the 0.9.6 version...

Hmm this forum seems a bit odd, not spreading out the words to read as normal, always seems to be bunching up the words and make the posts TALL & NARROW, odd...

You sleeping on me? lol...

Any thoughts to my last reply?

ROCKNROLLKID's picture

If you use the "Add new comment" button on the bottom of the top post it will prevent it from clustering together like that.

To answer your main question, Andrew will be releasing a 1.5 beta version soon, but I am not sure if he has fixed this issue, yet. Sorry for keeping you guys waiting.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Ahhh Add New Comment ok...

I'm using 1.5 from git it seems to be working, I was only asking to clarify for Andrew to help him, just to make sure it's doing what he wants...

Ahh no worries on repiles, I'm moren like a kid in a candy store excited to check out the new candies when they arrive LOL...

BBUser,

Sorry for the delay. I reviewed your 9/18/2014 comment. This is what I mean: please pick one of the sections that is hidden that should not be hidden (say, Google Chrome), and then run a preview for that section. Does it find any files to clean, or is the preview empty?

---
Andrew, lead developer

Sorry this doesn't many sense to me what you just said, because I'm using 1.5 from git if you remember and everything is showing, nothing is hidden.

So what are you asking, to use 1.4 and try it? Also how can I pick something that is hidden that I don't see and run a preview on it?

Hmm I'm lost, hehe... :/

TYPO:

Sorry this doesn't make sense....

Sorry for being confusing. Does this help?

  1. Please use the latest version (e.g., 1.5.2 from Git).
  2. Enable auto-hide
  3. Make a note of which cleaners are NOT hidden (e.g., Firefox, Bash)
  4. Enable auto-hide
  5. Make a note of which cleaners are now shown that were previously hidden (e.g., Google Chrome)
  6. Run a preview for cleaners that are now shown that were previously hidden
  7. Make a note of whether the preview shows any files

If #7 never shows any files, then auto-hide is working correctly. If #8 shows any files, then auto-hide is broken (even in the latest version you are testing).

---
Andrew, lead developer

ROCKNROLLKID's picture

Sorry for this sort of hijack but I have a question. How do I download the 1.5.2 version from github I don't see a download link or anything like that. Do you have a direct download link at all?

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

No autodhide in Linux version, so I'm assuming it's 'hide irrelevant cleaners'

1. I did hide irrelevant cleaners, this is what I now see;
bash
deep scan
firefox
flash
gimp
system
thumbnails
Transmission
xchat

2. I unchecked 'hide irrelevant cleaners', now this is what I see;

Adobe Reader
aMsn
APT
Audacious
Beagle
Chromium
Downloader for X
Easytag
ELinks
emesene
Epiphany
Evolution
Exaile
Filezilla
gedit
gFTP
GL-117
GNOME
Google Chrome
Google Earth
Google Toolbar
gPodder
Gwenview
Hippo OpenSim Viewer
Java
KDE
Konqueror
LibreOffice
Liferea
Links 2
Midnight Commander
Miro
Nautilus
Nexuiz
Octave
OpenOffice.org
Opera
Pidgin
RealPlayer
Recoll
Rhythmbox
Screenlets
SeaMonkey
Second Life Viewer
Skype
sqlite3
Thunderbird
Tremulous
VIM
VLC
Vuze / Azureus
Warzone 2100
WINE
winetricks
X11
xine
yum

3. For the items I have checked the Preview shows, so I'm not sure I understand how it's broke if it shows? It appears to work fine...

I'm still having this problem a year later, now with 1.9.2 there are only 4 options showing;

Deep scan
Firefox
System
Thumbnails

This forum layout is making me dizzy LOL...

Sorry I forgot to uncheck the hide irrelevant cleaners, so I see them all now.

But just to make sure how many should I see in Linux?

thank you

BBUser: If you have auto-hide enabled, the quantity depends mainly on what files are on your system. For example, Google Chrome is hidden unless (1) it is enabled or (2) there are any Google Chrome files that exist on your system.

If you have auto-hide disabled, then you will see about 70 cleaners in BleachBit 1.10 on Linux. Most of them are listed here https://github.com/az0/bleachbit/tree/master/cleaners

---
Andrew, lead developer