0.7.4 fails with errors

Forum tags: 

I have just updated from version 0.7.3 to 0.7.4
I am using Windows XP.

BleachBit opens but fails to execute Preview. The following is the traceback from BleachBit.exe.log

Traceback (most recent call last):
File "bleachbit\GUI.pyo", line 595, in
File "bleachbit\GUI.pyo", line 338, in preview_or_run_operations
File "bleachbit\Worker.pyo", line 31, in
File "bleachbit\DeepScan.pyo", line 31, in
File "sqlite3\__init__.pyo", line 24, in
File "sqlite3\dbapi2.pyo", line 27, in
File "_sqlite3.pyo", line 12, in
File "_sqlite3.pyo", line 10, in __load
ImportError: DLL load failed: Invalid access to memory location.

I have rebooted, uninstalled and reinstalled but get exactly the same response each time. Any clues?

(It's nice to see another good Drupal site.)


Hmm. Try replacing sqlite3.dll with the one here http://sqlite.org/sqlitedll-3_6_23_1.zip and let me know whether that helps. I wonder if your antivirus scanner is causing a conflict, so another option is temporarily disabling the antivirus.

Andrew, lead developer

I had tried disabling my anti-virus but no change. But replacing sqlite3.dll did the job. Many thanks.

Since this works on mine, could you tell me more about your system? Windows XP SP3? Home or Pro? English? Which anti-virus/security software?

Andrew, lead developer

Dell Inspiron 1520
3GB memory
Windows XP Pro SP3 fully updated
Bit Defender Anti-virus 2010 but I turned it off and it made no difference.
I run Glary Utilities as a registry cleaner but I haven't had any conflicts before or now and in any case it's a one time run like BB.
Windows firewall although I turned it off and it made no difference.
What else might be relevant?

I have a test machine with Windows XP SP3 Pro English and MSIE 7. BleachBit 0.7.4 ran fine. Then I installed Bit Defender Anti Virus 2010, rebooted, activated Bit Defender, and BleachBit had the same error. Then I turned on Bit Defender's game mode (which disables some of the Bit Defender real time protection), and BleachBit works fine. I'll look into reporting this to Bit Defender.

The reason the replacement sqlite3.dll works is it isn't shrunk. In BleachBit 0.7.4 I use two techniques (stripping and UPX compression) to shrink sqlite3.dll and other executables/libraries.

Andrew, lead developer

Thanks for the feedback.