purple screen

Forums: 

See this error message I grabbed.... Bleachbit hits an error and my screen goes purple and desktop dissappears after running it,

I have to power off and reboot then it's okay again. Here is the error log...
Can anyone tell me what I can do to prevent this
I'm running the latest Bleach Bit.....

Unable to queue locked file for deletion, even with administrator rights: C:\Windows\temp\SafeZone Installer
Mark for deletion 0 C:\Windows\temp\SafeZone Installer
Delete 0 C:\Windows\temp\_avast_
Delete 0 C:\Windows\temp\CProgram FilesAVAST SoftwareSZBrowser1.48.2066.101SZBrowser_autoupdate.download.lock
Delete 2.7kB C:\Windows\temp\lpksetup-20160823-072826-0.log
Delete 7.7kB C:\Windows\temp\winstore.log
Delete 39.1kB C:\Windows\SoftwareDistribution\Download\33d8a4b8183134ca79120bb436c18ddab713e713
Delete 166.9kB C:\Windows\SoftwareDistribution\Download\52e927c72db09728b8ca01575315e6a79402460d
Delete 41.6kB C:\Windows\SoftwareDistribution\Download\94abe7d9a36e38e87eeb49d81699059df1879a87
Delete 39.1kB C:\Windows\SoftwareDistribution\Download\c3248eb572cb5f82e63ce9c6d73cfbf39b1052ae
Delete 0 C:\Windows\SoftwareDistribution\Download
Error in execution of
Traceback (most recent call last):
File "bleachbit\Worker.pyo", line 84, in execute
File "bleachbit\Command.pyo", line 147, in execute
File "bleachbit\FileUtilities.pyo", line 383, in getsize
error: (123, 'FindFirstFileW', 'The filename, directory name, or volume label syntax is incorrect.')

That is weird. Do you get the same symptoms with a preview too?

---
Andrew, lead developer

ROCKNROLLKID's picture

Are you on a Windows 10? If so, the purple is actually a BSOD.

Can you try disabling/unchecking the entry Windows Explorer - Thumbnails and see if that solves the issue.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

With a preview it is okay - it just runs the preview

Here is the last few lines of script it shows in preview

Delete 39.1kB C:\Windows\SoftwareDistribution\Download\c3248eb572cb5f82e63ce9c6d73cfbf39b1052ae
Delete 0 C:\Windows\SoftwareDistribution\Download
Delete 128B C:\Users\donstedman\AppData\Local\Microsoft\Windows\Temporary Internet Files\counters.dat
Delete the usage history ?B C:\Users\donstedman\AppData\Roaming\OpenOffice.org\3\user/registrymodifications.xcu

Disk space to be recovered: 21.8MB
Files to be deleted: 526
Special operations: 16

Its windows 8

But I got my first BSOD about a week ago (unrelated to Bleachbit)
- obviously something's wrong with my set-up...

Which entry in Win Explorer do you want me to disable please?

I upgraded OS from win 8 to win 8.1
Ran bleachbit 1.12 and the same screen crash happened.
Unistalled that version and downloaded v1.11
Installed that and the screen crashed out again
:-(

biobalance: In the section called Windows Explorer please uncheck Thumbnails, if you have that checked. Let me know whether that helps.

If that does not cause a crash, then try each option one at a time. One way to do this is to right click on them. This troubleshooting step may help us figure out what is wrong and how to fix it.

It is strange that I do not recall any other crashes like this for any user.

---
Andrew, lead developer

ROCKNROLLKID's picture

Something being cleaned in SoftwareDistribution\Download might be causing this, too, as not everything in there is always useless.

@Andrew: Do you remember which entry is responsible for cleaning this? I would recommend trying to disable this entry, if disabling thumbnail cache entry doesn't solve this.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

SoftwareDistribution is deleted by System - Update uninstallers

---
Andrew, lead developer

Thanks very much Andrew,
Unchecking the checkbox thumbnails has fixed the issue.
It ran fine, without any drama.....
I then downloaded the latest version and ran that, no problems,
Thanks for the great software!