Browsers and programmes not showing up in the left hand side on page

Forums: 

Hi,

I've just installed this on my Opensuse Linux Leap 42.1 system. I'm only using V1.06, it says V1.12 is available, but there doesn't appear to be a download for Leap 42.1, just up the OPensuse 13.2....

Anyway...when I open the programme up, on the left hand side there is a list of things such as "API", "bash", "deep clean", "system" and "X11".....that's all that is there; but upon seeing some videos/tutorials I'm led to believe I should be seeing other things such as "firefox" "chromium", "open office" and so on...any ideas as to why I'm not seeing these, despite these programmes being on my system?

Many thanks in advance

Ross

ROCKNROLLKID's picture

Try disabling "Hide irrelevant cleaners" and see if they show up then.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Hi, I found out if I don't use the "bleachbit as super user" or root, then they appear. But I couldn't find that function.

Any idea if version 1.12 is available on opensuse LEAP 42.1?

Many thanks for you help, and quick reply too :D

ROss

Also - forgot to say....are there any ways of easily adding other cleaners? On linux I use KTorrent (instead of something like Vuze)...is there a way of cleaning these temp files etc? I must admit I use opensuse as a "windows" user and try to avoid command lines etc so if there's an easy way of doing this, that'd be marvellous. With windows it appears that it just downloads it all by itself and "job done" as it were.

If there is a later version of BleachBit that works with Opensuse LEAP 42.1 I would VERY much appreciate it if you point me in the right direction, and let me know how to install it (ideally one of the "1-click" links if possible!!

Cheers

ROCKNROLLKID's picture

I am not sure if there is a build for OpenSUSE leap 42.1. I am only a Windows user. I suppose Andrew can make a build for that version though.

Go to Preference, then go to the Custom tab. There you can add custom files and folders to there for which you want to be cleaned.

Please note if you do not run it with full root privileges, there may be some files that cannot get deleted due to requiring full root rights.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Thank you. Yes, hopefully there can be an update to the one I'm using, or he can point me in the direction of it if there's already one out there.

Many thanks once again.

I filed the request for OpenSUSE Leap here: https://github.com/bleachbit/bleachbit/issues/179 For now you could try install the .rpm for an older OpenSUSE. Sometimes this strategy works. I think this is what you said you did.

As to why they do not show up as root: when you start BleachBit as root, do you see a warning message in the log? It should tell you that you are running under the root account, so it would be cleaning root's Firefox, root's Google Chrome, etc. Because you should not be running normal applications as root, there are no files to clean. Run as root just to clean the shared parts of the system such as localization files.

---
Andrew, lead developer

For more details on running as root vs a normal account, please see the BleachBit FAQ

---
Andrew, lead developer

Hi,

Thank you for your reply. I have tried downloading the .rpm for Suse 13.2 and that is also version 1.6, so it appears that the latest version for SuSE is a little out of date. Many thanks for filing the request.

Yes, I figured it was because I was running as root, when I run it as my normal user then they appear :)

I run KTorrent instead of vuze on Linux, I'm not sure if this stores files in the temp directory or what....but there isn't a "cleaner" for this programme....whether cleaning the system with bleachbit will target these files, I've no idea.

I have heard of people running into issues using bleachbit when cleaning KDE, so I didn't do that. Once it had finished my taskbar vanished and my desktop wouldn't respond, so I pressed the power button on the tower to shut it down, and upon reboot it came back and worked fine (although it had erased some font size settings I have adjusted) but otherwise it seems to work very well.

On Windows, in the past, I have used CyberScrub Privacy Suite....it seems bleachbit does basically the same thing, but it's free :)

Thanks one again. If you could potentially keep me posted RE updates I'd be very grateful. It's just a bit weird having the programme tell me there's an update, when for the version of Linux I'm using....there isn't one.

Ross

BleachBit version 1.6 is old and should not be used. Please try a newer version of BleachBit from https://www.bleachbit.org/download/linux for the most similar SUSE distribution. If you install BleachBit 1.12, right now it will not tell you there is a BleachBit update.

BleachBit version 1.10 (newer than 1.6) had a fix to not delete xauth files for KDE, so BleachBit 1.10 and 1.12 and newer versions should be safe for KDE.

---
Andrew, lead developer

There is no version 1.12 for SuSE Leap 42.1 though....or is there? If so, could you please point me in the direction to the download link?

Many thanks

No, there is not BleachBit 1.12 for Leap 42.1. BleachBit 1.12 has packages for SLE 11, OpenSUSE 13.1, OpenSUSE 13.2.

The next BleachBit alpha (maybe this week) release should include openSUSE_Leap_42.1. You can get notified by Twitter, Facebook, RSS, or by checking the news page here.

---
Andrew, lead developer

Aha....I uninstalled my old version, then in the konsole I used "sudo zypper in Bleachbit_file.rpm" and the installation worked. Upon opening bleachbit, it's now saying I'm using V1.12.

Time for another clean and see what happens! I'll facebook search bleachbit :)

Thank you once again for your help.

Aha....I uninstalled my old version, then in the konsole I used "sudo zypper in Bleachbit_file.rpm" and the installation worked. Upon opening bleachbit, it's now saying I'm using V1.12.

Time for another clean and see what happens! I'll facebook search bleachbit :)

Thank you once again for your help.

BleachBit version 1.19 adds .rpm installation packages for openSUSE Leap 42.1, 42.2, 42.3. Please test and let me know how it goes

---
Andrew, lead developer