Bleachbit Starts Slow First Time Opening...



In Windows 7 I saw this same issue with 1.8. The first time I start Bleachbit it has been taking anywhere from 20-40 seconds to open.

The sad thing here for me is I'm running a fast box, i7 CPU, 12GB ram and a SSD, there's just no reason for an app on these specs to take this long, it should open in 3-5 seconds, but it never does.

This is the only app on my box to open this slow...

Hmm, that is a long time. It sounds like it is accessing many files. For troubleshooting, would you try this?

1. In the preferences, disable automatic updates to Winapp2.ini
2. Open the folder %USERPROFILE%\BleachBit\
3. Rename or delete winapp2.ini file
4. Open BleachBit for the first time. (I assume you mean after rebooting Windows.)

Does this make it faster?

Andrew, lead developer

I unchecked the Updates when I first installed/started Bleachbit.

I don't have a %USERPROFILE%\BleachBit\, so no winapp2.ini, since I never enabled it.

This isn't the problem, something else is causing this lag.

Yes this is happening when I reboot, or when I first start the computer and start bleachbit for the first time, either way...

By the way I just booted into Win7 to test this, because I'm running dual boot with Linux, and it took like 35 seconds for Bleachbit to appear... :( This happened twice today, both times I booted into Win7 it took like 35 seconds to start each time...

No one else has been reporting slow starts in Windows?

Have you had any chance to look into this?


Is BleachBit installed or portable?

Is the BleachBit application (whether installed or portable) stored on the SSD?

For troubleshooting please try to disable your antivirus/security software or put it into game mode, and then try starting BleachBit.

Andrew, lead developer

Installed version...

Installed on a Samsung 850 Pro 128GB SSD...

I'm using Eset AV 8x and I set it to Gamer mode and it worked!

Then when I disabled Gamer Mode and rebooted and tested this over, it's still working.

I don't get why enabling/disabling Gamer Mode in Eset now has this working?



I am on a Samsung 840 EVO SSD with 16GB ram and a AMD 6200 FX on a Windows 10 system. I have never been able to replicate a slow down like this. The most time BleachBit has taken to load for me is usually around 5 seconds.

By the way, a little off topic, is the 850 Pro good? I was going to get one of those, but at the time, they were expensive and the 840 EVOs were on sale, so I went with one of those.

Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam:

Windows 10 x64 (switching to ReactOS in the future).

Bleachbit 1.8 and 1.10 have always been slow in Windows 7 until I enabled and disabled Game Mode in Eset. I really don't get how this helped, and with it disabled, still working good... hmm

I've had the 850 for a little over a year, working great!

BBUser, based on your troubleshooting, Eset is doing extra scanning that slows down BleachBit, and gamer mode bypasses it.

I will look into submitting my software to Eset, so they can whitelist the application.

Andrew, lead developer

Sounds good...

But I enabled, then disabled game mode, so when I disabled it and put it back to default, I still don't get why Bleachbit would continue to open fast? I assumed Game Mode would have to be enabled for this to continue working?


Every time BleachBit opens it takes certain steps (loads the executables, configuration, and data), and the Eset antivirus is getting stuck somewhere here. The Gamer mode bypasses some of these scans.

The good news is I submitted a whitelist application to Eset, and they started processing it. Maybe when they finish processing it and roll out the update to users will it feel faster for you. I will let you know.

Andrew, lead developer

ESET should have rolled out this update by now.

Andrew, lead developer