Bleachbit portable v.1.6 won't load


I have a strange problem which I can't resolve. I have tried to search for answers, both on here and the internet, with no success.

It happened when I updated my Nvidia drivers. I uninstalled the drivers, restarted Windows 8.1 x64 in Safe Mode, ran CCleaner then Bleachbit, restarted again and installed the drivers. From then on Bleachbit portable will not run.

What seems to happen is the CPU usage stays at about 30% for as long as you want to leave Bleachbit running for. You have to end Bleachbit's task to stop this CPU usage. It's almost like Bleachbit is trying to process something and is stuck in a loop.

I thought I had success when I re-downloaded the portable version of Bleachbit and it ran straight away. But my problem came back as soon as Bleachbit had downloaded the new winapp2.ini file.

This is where it's gets strange. I copied the portable Bleachbit folder to a USB stick and ran Bleachbit on another computer just fine. It seems to be just my own computer that Bleachbit refuses to run on. So there must be a residual file or setting that Bleachbit is held up on, but I can't work out what this file or setting is.

I hope somebody can help me. I'd hate to have to reinstall Windows just for the sake of Bleachbit!

One option is to delete bleachbit.ini, and then disable online updates. If this resolves the symptoms, then we know for troubleshooting purposes that the problem involves online updates.

Another option is trying BleachBit 1.7.6 alpha, which includes fixes for the start-up process, though I have never seen the symptom you are describing with the CPU and freezing.

(By the way, in the next few days I plan to release 1.7.7 beta.)

Let me know how it goes.

Andrew, lead developer

Well instead of deleting just the BleachBit.ini file, I just deleted the entire folder and, re-downloaded BleachBit portable and put it back on my USB stick. I've even tried running BleachBit from my C: drive and I get the same issue: it hangs after updating and won't load up unless I delete winapp2.ini from the cleaners folder.

I've also tried v1.7..6 after I came across it on these forums purely out of chance. The very same thing happens with that, too.