BleachBit 2.3.1309 - Shred File error

Forum tags: 
Forums: 

In the lastest buld I tried shredding files but it doesn't work
When I hit on Shred File I get this error

Excepcion al ejecutar la operacion <<_gui>> <>
Traceback (most recent call last):
File "Bleachbit\Worker.pyo" line 358, in run_operations
File "Bleachbit\Worker.pyo" line 181, in clean_operations
File "Bleachbit\GUI.pyo" line 838, in update_item_size
File "g\overrides\Gtk.pyo" line 844, in get_iter
ValueError: invalid tree path '0'

Either I click on Delete or Cancel it closes automatically

Thanks,
William

BleachBit version: 
2.3.1309
Your operating system: 
Windows 8.1

Excepcion al ejecutar la operacion <<_gui>>:

Sorry this is the first line amended

I tried to reproduce it on Ubuntu 19.04 and Windows 10, but I could not. Still, I added a workaround. Please try build 2.3.1310 or later. It will need about 10 minutes to finish building.

As far as reproducing it, I wonder whether you could post a screencast (with bhild 2.3.1309). I'm wondering if I am doing it differently than you. Also, I wonder whether the tree view (the list of checkboxes on the left) is empty on your system.

---
Andrew, lead developer

Latest build showed this error:
ValueError in get_iter() when update file size for free path=()
ValueError in get_iter() when update file size for free path=()

I don't know how to post a screenshot or video here
I just selected a file in Desktop and clicked on Shred with BleachBit in the conext menu
When I open BleachBit and click on Shred Files and select one, this error doesn't show up, only when I click directly on the file
I checked most of the checkboxes in the left, by the way

To post a video, record it on any site (such as YouTube) and then post the URL here, but your new description helped me reproduce the error. I filed the problem as issue 648

---
Andrew, lead developer

I think I fixed it in CI build 2.3.1314. Would you please try again?

---
Andrew, lead developer

Hi Andrew
I find it fixed, since I tried last CI build with several file extensions and I couln't reproduce that error again

Thanks so much

Thanks for confirming the fix, WilliamBE

---
Andrew, lead developer

Anytime, Andrew

Regards,
William Beltrán