Test results for BleachBit 1.1

Forums: 

I didn't test everything out yet, but so far I was able to test out most of the top priorities for this version.

- Shred integration did not install when it was unchecked and did install when it was checked.

- Warzone 3.1 cleans out successfully.

- Free space did not drag when starting and same amount of free space was there when canceled. I did not run free space all the way through, yet. I will do that another time and report back on the test results for that.

- As a bonus, the cleaner seems to be running slightly faster then 1.0 during cleaning sessions.

Issues still present in BleachBit:

- BleachBit still hangs when cleaning out entries with large amount of files (steam entries).

- Using the "Start BleachBit with Computer" does not automatically run cleaner on start up. It just opens up BleachBit's main page.

ROCKNROLLKID's picture

So I tested out free space wiper and everything went fine. No free space was missing and everything is workign normally.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Thank you for testing.

The Steam issue is open in Launchpad and targeted for a future release.

Regarding "Start BleachBit with Computer": it's labeled "Start" because "start" is all it does, so this is more of an enhancement request than bug. But I'm not sure if running automatically is generally safe because people may forgot to set their options before restarting the computer. For now please consider using the command line options with --clean

---
Andrew, lead developer

ROCKNROLLKID's picture

I got this error message after I did a free space test today.

[Errno 2] No such file or directory: 'C:\\tmp_kifm_DC31s2usKq.kZFDQQ7O3S.5kbPkLSSMv2UOqMc1qTb-rHlpJz89YByuIWv4Q-IktIWmw02R3wxo_4oZimn05.CigQdBNEMxXzEquo70oUcHqHW5QKiYFRhDcJWrplul5BFx2oakkEtDtK-4nYlmow6TLv2r4PjSdZXIAYB34Rh15ITiKlZk4FVNvFjc2ske3n1SPuNdp_El.kzegvbGBkWdUisoiZ8pUYQOLkOprEq_dOp7nv.D1Q'

It is weird because I didn't get it the first time. I don't know what it means. I had everything checked, all entries including free space, pass wipe enabled, run as administer, and nothing else running.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Assuming this file doesn't actually exist in c:\ then it is a harmless error.

I filed this as bug 1323908 on Launchpad for a future release

---
Andrew, lead developer

ROCKNROLLKID's picture

I got the same issue, once again, but a different file.

[Errno 2] No such file or directory: 'C:\\tmp1tya7n4fYTYn1j0TcQfwDC1ym_7T-KtQAW5F8mVftmobSa8BM_upqTwKjRJ-9sgQBf_-F9fkSwFAcAUAsX9cnPxzub0jNRIHUW9RMOd4u1xA3Bk9.Brbbkg_AQxh_DDHu10F3l.UMeMwY_TW7eMx.38Ie64veESgrCY4llWlbL6ZdWo-peTnlZOrtot9CH.OXUJm5TpxR8SyENa49xzmiw0PDhVs1Fa2cnSTE0YB_IAUSFQqpdpSOGyc3n'

So there is definitely some kind of bug in free space wiper. Just figured I'd confirm that with you.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

Yes, that's what it looks like. It's logged in Launchpad, and because it's not a show stopper, I plan to look at it more closely after the next release.

---
Andrew, lead developer

The error message "[Errno 2] No such file or directory" related to wiping free disk space is fixed. Please see 1323908 for a link to a test build for Windows, and please continue any discussion related to this bug on that ticket. (It helps me keep it organized.) Thank you

---
Andrew, lead developer

I don't really know if this is the correct place for this, but there seems to more discussion about the Steam issue that I am having - it is so bad that BleachBit v1.8 won't even load.

My Steam folder is quite big - its total size is 15.1 GB and consists of nearly 65,000 files and 3,200 folders.

I have found that BleachBit will suddenly load without any apparent effort of resolution on my part. Whenever I use the Steam cleaning functions in CCleaner, BleachBit won't load and will hang for as long as I allow. When BleachBit does load and I try to use any of the Steam cleaning functions, BleachBit will hang until I end the task in Task Manager.

Maybe this is a coincidence, but I did find BleachBit ran after I moved the entire Steam folder from one physical drive to another.

I am in the process of trying other things and will report if I can find some sort of work around.

ROCKNROLLKID's picture

Andrew has this issue tagged for the next release, however, I have noticed he has been bumping it up 1 version each time the next version gets released. I know he was also looking for some help with it, but I don't think he found anyone to help him, yet.

About your issue, that doesn't sound exactly the same as to what I was having. On mine, all that happened was it made previewing much much slower, but on yours, you say it doesn't even load at all. Has this happened the same way with previous releases?

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).