A minor issue with HKCU registry keys

Forums: 

Using Windows 7 Pro SP1, can you advise which options should be deselected so that BB ignore these registry keys. I am unable to retain the Windows explorer display columns order as I set it after running BleachBit. It reverts to the default.

HKCU_Software_Classes_LocalSettings_Software_Microsoft_Windows_Shell_BagMRU.reg
HKCU_Software_Classes_LocalSettings_Software_Microsoft_Windows_Shell_Bags.reg
HKCU_Software_Microsoft_Windows_Shell_BagMRU.reg
HKCU_Software_Microsoft_Windows_Shell_Bags.reg

ROCKNROLLKID's picture

Moved this to the support thread.

You will need to exclude all 4 of them in order to preserve your folders view settings. They all seem to play a role in it.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

ineuw's picture

Are referring to placing it in the whitelist? How do I exclude registry keys? If not, which options do I uncheck???

Linux Mint Cinnamon 20. 0 64bit

ROCKNROLLKID's picture

The entry is under the "Microsoft Windows" section and it will be named "ShallBags". You can uncheck that entry and it should fix your issue.

I believe, if you check that entry, a warning is displayed which it will tell you what it does, for future reference.

____________________
Also known as Alex.

Moderator for BleachBit and a maintainer for Winapp2.

Check out my open-source group on Steam: http://steamcommunity.com/groups/opencommunity

Windows 10 x64 (switching to ReactOS in the future).

This comes from Winapp2.ini, and instead of whitelisting, I suggest unchecking this option called ShellBags.


[ShellBags*]
DetectOS=6.1|
LangSecRef=3025
Detect=HKCU\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell
Default=False
Warning=This will delete window size, window position and view setting of all folders.
RegKey1=HKCR\Local Settings\Software\Microsoft\Windows\Shell\BagMRU
RegKey2=HKCR\Local Settings\Software\Microsoft\Windows\Shell\Bags

---
Andrew, lead developer

ineuw's picture

Now it works. I found the entries on the left panel and disabled it. After running BB the Windows folder settings remained the same. Thanks again.

Linux Mint Cinnamon 20. 0 64bit