Errors when cleaning with BleachBit 2.0

Forums: 

Hello,
I get the following errors when cleaning with the current last version of BleachBit (from CI) 2.0.696.

Error: system.tmp: Command to delete C:\Windows\temp\8B036B44-FB9C-43F8-9C83-9DC9CDB3B9CBcf0.1d3c0b7e67bbc82\nisfull.vdm
Error: winapp2_windows.ms_search: Command to delete C:\Users\HP 19 2013LA\Searches\Everywhere.search-ms
Error: winapp2_windows.ms_search: Command to delete C:\Users\HP 19 2013LA\Searches\Indexed Locations.search-ms
Error: winapp2_windows.windows_log_files_extras: Command to delete C:\Windows\Logs\CBS\CBS.log

It happened in Windows 8.1 64-bits

BleachBit version: 
2.0
Your operating system: 
Windows 8.1 64-bits

Thank you for the bug report. It would be helpful if there were more detail.

#1 If you run bleachbit_console.exe, is there a more detailed error message in the console window (the window with the black background)? If so, please copy and paste the error message here. (In the future, I will try to make this easier.)

#2 Could you check whether the files are locked? You could try renaming one of them. If it is locked, Windows Explorer not allow you to rename it.

---
Andrew, lead developer

This is the detailed info gathered from BleachBit console:

Error: system.tmp: Command to delete C:\Windows\temp\z\nisfull.vdm
Traceback :
File "bleachbit\Worker.pyo", line 83, in execute
File "bleachbit\Command.pyo", line 84, in execute
File "bleachbit\FileUtilities.pyo", line 287, in delete
File "bleachbit\FileUtilities.pyo", line 672, in wipe_contents
File "bleachbit\WindowsWipe.pyo", line 917, in file_wipe
File "bleachbit\WindowsWipe.pyo", line 432, in open_file
error: <5, 'CreateFileW', 'Acceso denegado.'>
directory is not empty: \\?\C:\Windows\temp\p
directory is not empty: \\?\C:\Windows\temp\z
Error: winapp2_windows.ms_search: Command to delete C:\Users\HP 19 2013LA\Searches\Everywhere.search-ms
Traceback :
File "bleachbit\Worker.pyo", line 83, in execute
File "bleachbit\Command.pyo", line 84, in execute
File "bleachbit\FileUtilities.pyo", line 287, in delete
File "bleachbit\FileUtilities.pyo", line 672, in wipe_contents
File "bleachbit\WindowsWipe.pyo", line 917, in file_wipe
File "bleachbit\WindowsWipe.pyo", line 432, in open_file
error: <5, 'CreateFileW', 'Acceso denegado.'>
Error: winapp2_windows.ms_search: Command to delete C:\Users\HP 19 2013LA\Searches\Indexed Locations.search-ms
Traceback :
File "bleachbit\Worker.pyo", line 83, in execute
File "bleachbit\Command.pyo", line 84, in execute
File "bleachbit\FileUtilities.pyo", line 287, in delete
File "bleachbit\FileUtilities.pyo", line 672, in wipe_contents
File "bleachbit\WindowsWipe.pyo", line 917, in file_wipe
File "bleachbit\WindowsWipe.pyo", line 432, in open_file
error: <5, 'CreateFileW', 'Acceso denegado.'>

- I found the file "nisfull.vdm2 in a folder named "s" instead of "z" and it allows me to change its name
- The file "Everywhere.search-ms" (Todo in spanish) allows me to change its name
- The file "Indexed locations.search-ms" (Ubicaciones indizadas in spanish) allows me to change its name as well

I hope this helps.

PD: I'm having a trouble with default programs, since, once I use BleachBit it restart all of them and despite I change them back it doesn't seem to work. Is there something I'm using wrong?

About the "access denied" error:

1. In BleachBit click Help - System Information
2. Look for a line like this "win32com.shell.shell.IsUserAnAdmin"
3. Is it True or False? It should be True

About default programs: I believe that is not a symptom of the standard function of BleachBit. It may be related to one of the Winapp2.ini cleaners. If so, it should give a warning when its checkbox is enabled.

---
Andrew, lead developer

Help / System Information:
win32com.shell.shell.IsUserAnAdmin() = True

Regarding to default programs: I between all the warnings I don't see any related to the default programs. Is there some way to get to know what is causing this?

Regarding the "access denied" error. I do not have an immediate solution, but I would like to research and fix this. I would appreciate it if you could file a bug ticket at GitHub, so it does not get lost. The description there can be a link back to this forum thread.

Default program: I am not sure. Resetting default programs is not a standard feature in BleachBit. Assuming it came from Winapp2.ini, perhaps you could contact the people who maintain it. Here is their bug tracker. Alternatively, for general Windows support you could try a general forum such as superuser.com

---
Andrew, lead developer

Bug reported at GitHub:
https://github.com/bleachbit/bleachbit/issues/337
And I also filed another one for the Winapp issue. Crossing fingers they'll solve it.

Thank you Andrew.