Bleachbit doesn't clean firefox 6

Forums: 

I've noticed that when I used bleachbit my firefox history and possibly all the other stuff wasn't clean, all the other options work as intended.

Also I've tried ccleaner to clean firefox and it works, so it's not a firefox issue.

Any help please? I'm using firefox 6 if it matters

thank you

I haven't noticed any problems, so please help me reproduce the problem

  1. Which operating system? Windows 7? Ubuntu 11.04?
  2. Which version of BleachBit? 0.9.0?
  3. Does BleachBit show any errors? (Look for red lines in the log)
  4. Do you have multiple or special Firefox profiles?
  5. Are the remaining history items also bookmarks?
  6. Did you try Firefox 5 or earlier? Did that work?

---
Andrew, lead developer

1. Windows 7 x64
2. Bleachbit 0.9.0
3. Not on firefox. I've also noticed the same thing happening with chromium, on chromium I get an error

Delete 53.2kB C:\Users\joao\AppData\Local\Chromium\User Data\Default\Archived History
'url'

the 'url' part being in red

4. no
5. everything remains, not just a part of my history
6. nope, now that I noticed it's not a firefox-only issue, I don't think that would make a difference, but I'll try it if it's needed

any info on this?

I just tested Windows 7 64-bit with BleachBit 0.9.0 (portable) and Firefox 6.0.2 and McAfee antivirus. It cleaned the history and cookies just fine. All the cookies were gone, and the only remaining history items were also bookmarks.

More things for you to try

  1. Run bleachbit_console.exe instead of bleachbit.exe. They are in the same folder c:\program files (x86)\bleachbit\
  2. Right click on Firefox - URL history and choose Preview. First, note that there should be at least one file previewed. Second, check the path (C:\Users\joao\...) represents the user account you use Windows with (and not some guest or administrator account, for example).
  3. Search for places.sqlite in c:\users, and you should have only one copy.

---
Andrew, lead developer

Thanks for your reply

1. same thing
2. there isn't, i'm sure about the path thing
3. there isn't. the places.sqlite is in my "%appdata%\Mozilla\Firefox\Profiles\my profile name" folder. should it be in c:\users?

oh, about 3 you mean really search, I have

places.sqlite-wal
places.sqlite-shm
places.sqlite

all from firefox's profile folder. also I have another places.sqlite from thunderbird

I'm assuming you have the problem still with BleachBit 0.9.2 and Firefox 9. If so, send me an email by clicking on my name which is on the footer of every web page on this site. We can try screensharing on TeamViewer or Skype, and I can operate your system for a few minutes to try to figure this weird thing out.

---
Andrew, lead developer

Hello. OP here, I think I have found the problem: so

- I noticed the path bleachbit was looking for was C:\Users\joao\AppData\Local ..etc
- But, apparently my mozilla folder is in C:\Users\joao\AppData\Roaming\

So it seems bleachbit is looking in the wrong place? or is there a problem with my firefox installation?

I also tried deleting the local mozilla folder, hoping that bleachbit could maybe locate the correct one, but that made firefox disappea from the list in bleachbit

Hello. OP here, I think I have found the problem: so

- I noticed the path bleachbit was looking for was C:\Users\joao\AppData\Local ..etc
- But, apparently my mozilla folder is in C:\Users\joao\AppData\Roaming\

So it seems bleachbit is looking in the wrong place? or is there a problem with my firefox installation?

I also tried deleting the local mozilla folder, hoping that bleachbit could maybe locate the correct one, but that made firefox disappea from the list in bleachbit

I just noticed a thing that might not have been clear, sorry:

I *did* have an appdata\local mozilla folder, maybe from an old install? and that's the one bleachbit tried to clean every time.

That's the one I deleted, hoping bleachbit could locate the right one.